Questions about the Dato DUO

Hi there everyone!

Got my Dato DUO and boy, oh, boy…do I love this thing. Not a toy. Not at all!

But I’ve been having some trouble following everyone’s advices on other threads so I thought I might post here and see what you guys think!

Here goes :

  1. I tried many time to turn off the Dato DUO using the « Play button long press » but I just can’t get it to react. It was my understanding that it was the procedure to choose its MIDI channel, but I just can’t get it to react when long pressing Play.
  • I tried plug-in it in via USB-C to two MacBooks (M1 chips) and an iPad Air 5 (M1 chip too). But it won’t mount as an audio interface. Which it should do if I’m not mistaken. Am I missing something?

  • When plugged in my various audio interfaces, and when turning the AMP knob to the max in stand-alone operation, its volume is very low. Like, veeeeery low in comparison of other gears I own. Thus, resulting in a very high floor noise when recording it or syncing it. I’m using a mini stereo jack to a 1/4 stereo jack that works well with other gear. There again, am I at cause here?

It has to be noted, at that point, that I purchased my Dato DUO through a retailer that clearly sold me the Dato DUO as new when it wasn’t (opened box sealed with tape and no adapter for charging) - the retailer already reimbursed me a little bit for that, but now that I’m having trouble setting the Dato DUO up, I’m starting to think that my unit may be faulty and that I’m in for a return. The return window is closing in about a week, so I’m eager to know what you guys think about all this!

Cause if I have to return it, believe you me, I’m buying a new one asap!

Cheers, and thanks for your time!

Thanks for the praise :slight_smile:

  1. The « Play button long press » function is unfortunately not present on DUO’s from 2022 and later. We might be able to add it back in through a firmware update. For now, you can unplug the DUO and hold the key corresponding to the MIDI channel while plugging in the DUO.

  2. The DUO won’t mount as an audio interface. Only as a MIDI interface. You might need to press ‘Allow’ on the dialog that pops up:

  3. I’m not sure what is going on here. Could it be that your audio interface accepts balanced inputs only? If so, you could try using a mono mini jack to see if the audio level is higher.

We sell DUOs with and without adapters and it’s up to the retailer to clearly inform you in advance which one you are getting. It’s best to contact the retailer about this. From your description it doesn’t sound like your unit is faulty but of course you may always send an email to if you are unsure.

1 Like

Thanks a bunch. You guys are the best. Quick and detailed answers. My fave kind!
Got some tests to run, then!

Thought I’d update the thread.

Everything works fine in the end.

Changed the cable - it was at fault here - and now I can record the Dato DUO perfectly into my DAW.

As for the MIDI interface, it does work very well with Logic. Being able to record both audio and MIDI notes is very practical for later editing. Already wrote 5 arcade-ish tracks.
I don’t think I can record any automation from the DUO to the MIDI region in Logic. But still.

I’m gonna try to hook the Dato DUO to the OP1 Field later this week. It’s gonna be some kind of a ride, I’ll tell you that!

Thanks for the advice.

1 Like